dotfiles/nix/programs/helix.nix
leo 27507e96c5
home-manager: don't manage helix-program with hm
however, start managing helix config with hm
2023-03-22 19:28:48 +01:00

40 lines
820 B
Nix

{
config,
pkgs,
...
}: {
programs.helix = {
# TODO: integrate the full toml config.
enable = false;
settings = {
theme = "dracula";
editor = {
line-number = "relative";
cursor-shape = {
insert = "bar";
normal = "block";
};
whitespace = {
render = "all";
# or control each character
#render = {
# space = "all";
# tab = "all";
# newline = "none";
#};
characters = {
space = "·";
nbsp = "";
tab = "";
newline = "¬";
# Tabs will look like "→···" (depending on tab width)
tabpad = "·";
};
};
lsp.display-messages = true;
};
};
};
}