45 lines
862 B
Nix
45 lines
862 B
Nix
{
|
|
description = "Pentest templates";
|
|
|
|
inputs = {
|
|
nixpkgs.url = "github:nixos/nixpkgs";
|
|
};
|
|
|
|
outputs =
|
|
{ self
|
|
, nixpkgs
|
|
, ...
|
|
}:
|
|
let
|
|
supportedSystems = [ "x86_64-linux" "x86_64-darwin" ];
|
|
forAllSystems = nixpkgs.lib.genAttrs supportedSystems;
|
|
|
|
version = "0.0.1";
|
|
|
|
nixpkgsFor = forAllSystems (
|
|
system:
|
|
import nixpkgs {
|
|
inherit system;
|
|
overlays = [ self.overlay ];
|
|
}
|
|
);
|
|
in
|
|
rec {
|
|
templates = {
|
|
report-en = {
|
|
path = ./en-tmpl;
|
|
description = "A LaTeX pentest report";
|
|
};
|
|
report-sk = {
|
|
path = ./sk-tmpl;
|
|
description = "A LaTeX pentest report (in Slovak)";
|
|
};
|
|
};
|
|
formatter = forAllSystems (
|
|
system:
|
|
nixpkgsFor.${system}.alejandra
|
|
);
|
|
|
|
};
|
|
}
|