1
0
Fork 0
mirror of https://git.oat.zone/dark-firepit/dotfiles synced 2024-04-25 16:25:06 +02:00
git.oat.zone--dark-firepit-.../shell.nix
System administrator ec00c09f2e Dotfiles
2022-01-11 17:44:40 +00:00

18 lines
356 B
Nix
Executable File

{ pkgs ? import <nixpkgs> {} }:
with pkgs;
let nixBin =
writeShellScriptBin "nix" ''
${nixFlakes}/bin/nix --option experimental-features "nix-command flakes" "$@"
'';
in mkShell {
buildInputs = [
git
nix-zsh-completions
];
shellHook = ''
export FLAKE="$(pwd)"
export PATH="$FLAKE/bin:${nixBin}/bin:$PATH"
'';
}