mirror of
https://git.oat.zone/dark-firepit/dotfiles
synced 2024-11-22 17:01:57 +01:00
37 lines
451 B
Nix
37 lines
451 B
Nix
{ stdenv, lib, fetchpijul
|
|
, pijul
|
|
, rustc
|
|
, cargo
|
|
, rustfmt
|
|
, postgresql
|
|
, sqlx-cli
|
|
, libiconv
|
|
, xxHash
|
|
, zstd
|
|
, ... }:
|
|
|
|
stdenv.mkDerivation rec {
|
|
pname = "nidobyte";
|
|
|
|
src = fetchpijul {
|
|
url = "https://nest.pijul.com/zj/nidobyte";
|
|
hash = "YZAHAQRQHK24QY2H3AXKCPPDIE2F53H35C5CNYUSXRDSNCWOUJVQC";
|
|
};
|
|
|
|
nativeBuildInputs = [
|
|
pijul
|
|
|
|
rustc
|
|
cargo
|
|
rustfmt
|
|
|
|
postgresql
|
|
sqlx-cli
|
|
|
|
libiconv
|
|
|
|
xxHash
|
|
zstd
|
|
];
|
|
}
|