mirror of
https://git.oat.zone/dark-firepit/dotfiles
synced 2024-11-22 17:01:57 +01:00
50 lines
1.5 KiB
Nix
50 lines
1.5 KiB
Nix
{ fetchurl, lib, p7zip, stdenv }:
|
|
|
|
stdenv.mkDerivation {
|
|
name = "otf-apple";
|
|
version = "1.0";
|
|
|
|
buildInputs = [ p7zip ];
|
|
src = [
|
|
(fetchurl {
|
|
url = "https://devimages-cdn.apple.com/design/resources/download/SF-Pro.dmg";
|
|
sha256 = "+JF3SyNi+6rEVIEg/Llqu0w/z8gqBbbLtP3cCl9Kqjo=";
|
|
})
|
|
(fetchurl {
|
|
url = "https://devimages-cdn.apple.com/design/resources/download/SF-Compact.dmg";
|
|
sha256 = "SHZHMCpqlrLH/3cEbIcnZg4lDQYl765bVO3v1o1D6hg=";
|
|
})
|
|
(fetchurl {
|
|
url = "https://devimages-cdn.apple.com/design/resources/download/SF-Mono.dmg";
|
|
sha256 = "8niJPk3hGfK1USIs9eoxZ6GlM4aZ7ZObmQj2Zomj+Go=";
|
|
})
|
|
(fetchurl {
|
|
url = "https://devimages-cdn.apple.com/design/resources/download/NY.dmg";
|
|
sha256 = "MAxQkdR40YUDl7z0OYbuwiueOoB2JuYikIu11CqiAto=";
|
|
})
|
|
];
|
|
|
|
sourceRoot = "./";
|
|
|
|
preUnpack = "mkdir fonts";
|
|
|
|
unpackCmd = ''
|
|
7z x $curSrc >/dev/null
|
|
dir="$(find . -not \( -path ./fonts -prune \) -type d | sed -n 2p)"
|
|
cd $dir 2>/dev/null
|
|
7z x *.pkg >/dev/null
|
|
7z x Payload~ >/dev/null
|
|
mv Library/Fonts/*.otf ../fonts/
|
|
cd ../
|
|
rm -R $dir
|
|
'';
|
|
|
|
installPhase = ''
|
|
mkdir -p $out/share/fonts/opentype/{SF\ Pro,SF\ Mono,SF\ Compact,New\ York}
|
|
cp -a fonts/SF-Pro*.otf $out/share/fonts/opentype/SF\ Pro
|
|
cp -a fonts/SF-Mono*.otf $out/share/fonts/opentype/SF\ Mono
|
|
cp -a fonts/SF-Compact*.otf $out/share/fonts/opentype/SF\ Compact
|
|
cp -a fonts/NewYork*.otf $out/share/fonts/opentype/New\ York
|
|
'';
|
|
}
|