1
0
Fork 0
mirror of https://git.oat.zone/dark-firepit/dotfiles synced 2024-05-19 14:16:09 +02:00
git.oat.zone--dark-firepit-.../modules/dev/zig.nix
System administrator affdf52f23 refactoring
2022-04-20 09:53:28 +01:00

21 lines
348 B
Nix

{ config, options, lib, pkgs, ... }:
with lib;
let
cfg = config.modules.dev.zig;
in {
options.modules.dev.zig = {
enable = mkOption {
type = types.bool;
default = false;
description = "Adds zig tools to the environment.";
};
};
config = mkIf cfg.enable {
user.packages = with pkgs; [
zig
];
};
}