1
0
Fork 0
mirror of https://git.oat.zone/dark-firepit/dotfiles synced 2024-05-04 07:36:07 +02:00
git.oat.zone--dark-firepit-.../lib/default.nix
Jill "oatmealine" Monoids 39ec224d05 refactor authorizedKeys
2022-10-18 19:54:57 +02:00

18 lines
422 B
Nix

{ inputs, lib, pkgs, ... }:
lib.extend (self: super:
let
inherit (lib) attrValues foldr;
inherit (modules) mapModules;
inherit (helpers) getSSH getWG;
modules = import ./modules.nix { inherit lib; };
helpers = import ./helpers.nix { inherit lib; };
in {
_ = foldr (a: b: a // b) {} (attrValues (mapModules ./. (file: import file {
inherit pkgs inputs;
lib = self;
})));
}
)