1
0
Fork 0
mirror of https://git.oat.zone/dark-firepit/dotfiles synced 2024-04-25 16:25:06 +02:00
git.oat.zone--dark-firepit-.../default.nix
System administrator 9da0a143ae some refactoring
Co-authored-by: Jill Monoids <oatmealine@disroot.org>
2022-09-05 18:27:22 +02:00

40 lines
1.2 KiB
Nix
Executable File
Raw Permalink Blame History

This file contains ambiguous Unicode characters

This file contains Unicode characters that might be confused with other characters. If you think that this is intentional, you can safely ignore this warning. Use the Escape button to reveal them.

{ config, inputs, lib, pkgs, ... }:
let
inherit (lib) filterAttrs _;
in {
imports =
[ inputs.home-manager.nixosModules.home-manager ]
++ _.mapModulesRec' ./modules import;
# nix flake check bypasses, can be changed in the actual hosts
# config, useful for testing
fileSystems."/".device = lib.mkDefault "/dev/disk/by-label/nixos";
boot.loader.systemd-boot.enable = true;
boot.loader.efi.canTouchEfiVariables = true;
boot.loader.systemd-boot.configurationLimit = 10;
nix = let
registry = lib.mapAttrs (name: value: { flake = value; }) (filterAttrs (name: value: name != "attrs") inputs);
in {
package = pkgs.nixFlakes;
registry = registry // { dotfiles.flake = inputs.self; };
settings.auto-optimise-store = true;
settings.experimental-features = [ "nix-command" "flakes"];
settings.substituters = [
"https://nix-community.cachix.org"
];
settings.trusted-public-keys = [
"nix-community.cachix.org-1:mB9FSh9qf2dCimDSUo8Zy7bkq5CX+/rkCWyvRCYg3Fs="
];
};
environment.systemPackages = with pkgs; [
curl git wget neovim
];
i18n.defaultLocale = "en_US.UTF-8";
system.stateVersion = lib.mkDefault "21.05";
}