mirror of
https://git.oat.zone/dark-firepit/dotfiles
synced 2024-11-30 11:41:33 +01:00
21 lines
348 B
Nix
21 lines
348 B
Nix
{ config, options, lib, pkgs, ... }:
|
|
|
|
with lib;
|
|
let
|
|
cfg = config.modules.dev.zig;
|
|
in {
|
|
options.modules.dev.zig = {
|
|
enable = mkOption {
|
|
type = types.bool;
|
|
default = false;
|
|
description = "Adds zig tools to the environment.";
|
|
};
|
|
};
|
|
|
|
config = mkIf cfg.enable {
|
|
user.packages = with pkgs; [
|
|
zig
|
|
];
|
|
};
|
|
}
|