1
0
Fork 0
mirror of https://github.com/rust-lang/rustlings.git synced 2024-03-01 21:10:09 +01:00

fix(installation): bump MinRustVersion to 1.70

Since #1633 porting to Clap, min Rust version reqirement changes.
This commit is contained in:
d1t2 2023-09-22 11:32:39 +08:00 committed by GitHub
parent 06f865307f
commit 6aa47be78e
Signed by: GitHub
GPG Key ID: 4AEE18F83AFDEB23
2 changed files with 2 additions and 2 deletions

View File

@ -53,7 +53,7 @@ function vercomp($v1, $v2) {
}
$rustVersion = $(rustc --version).Split(" ")[1]
$minRustVersion = "1.56"
$minRustVersion = "1.70"
if ((vercomp $rustVersion $minRustVersion) -eq 2) {
Write-Host "WARNING: Rust version is too old: $rustVersion - needs at least $minRustVersion"
Write-Host "Please update Rust with 'rustup update'"

View File

@ -124,7 +124,7 @@ function vercomp() {
}
RustVersion=$(rustc --version | cut -d " " -f 2)
MinRustVersion=1.58
MinRustVersion=1.70
vercomp "$RustVersion" $MinRustVersion || ec=$?
if [ ${ec:-0} -eq 2 ]
then