gnu: Fix luajit installation
* gnu/packages/lua.scm (luajit): Apply 2 patches. * gnu-system.am (dist_patch_DATA): Register 2 patches. * gnu/packages/patches/luajit-no_ldconfig.patch: New file. * gnu/packages/patches/luajit-symlinks.patch: New file.
This commit is contained in:
parent
447260319b
commit
dcaf2511d7
@ -441,6 +441,8 @@ dist_patch_DATA = \
|
||||
gnu/packages/patches/libvpx-vp9-out-of-bounds-access.patch \
|
||||
gnu/packages/patches/lm-sensors-hwmon-attrs.patch \
|
||||
gnu/packages/patches/lua51-liblua-so.patch \
|
||||
gnu/packages/patches/luajit-2.0.3-no_ldconfig.patch \
|
||||
gnu/packages/patches/luajit-2.0.3-symlinks.patch \
|
||||
gnu/packages/patches/luit-posix.patch \
|
||||
gnu/packages/patches/m4-gets-undeclared.patch \
|
||||
gnu/packages/patches/make-impure-dirs.patch \
|
||||
|
@ -87,7 +87,9 @@ for configuration, scripting, and rapid prototyping.")
|
||||
(uri (string-append "http://luajit.org/download/LuaJIT-"
|
||||
version ".tar.gz"))
|
||||
(sha256
|
||||
(base32 "0ydxpqkmsn2c341j4r2v6r5r0ig3kbwv3i9jran3iv81s6r6rgjm"))))
|
||||
(base32 "0ydxpqkmsn2c341j4r2v6r5r0ig3kbwv3i9jran3iv81s6r6rgjm"))
|
||||
(patches (list (search-patch "luajit-symlinks.patch")
|
||||
(search-patch "luajit-no_ldconfig.patch")))))
|
||||
(build-system gnu-build-system)
|
||||
(arguments
|
||||
'(#:tests? #f ;luajit is distributed without tests
|
||||
|
31
gnu/packages/patches/luajit-no_ldconfig.patch
Normal file
31
gnu/packages/patches/luajit-no_ldconfig.patch
Normal file
@ -0,0 +1,31 @@
|
||||
From 629200f48e18dc1a3a5229739748bad0e2a6a0a2 Mon Sep 17 00:00:00 2001
|
||||
From: =?utf8?q?Tom=C3=A1=C5=A1=20=C4=8Cech?= <sleep_walker@suse.cz>
|
||||
Date: Wed, 4 Feb 2015 11:37:16 +0100
|
||||
Subject: [PATCH] Do not silently and prematurely end install when ldconfig is
|
||||
missing
|
||||
|
||||
---
|
||||
Makefile | 7 ++++---
|
||||
1 file changed, 4 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/Makefile b/Makefile
|
||||
index 343ecb5..4667146 100644
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -112,9 +112,10 @@ install: $(INSTALL_DEP)
|
||||
$(RM) $(INSTALL_TSYM) $(INSTALL_DYN) $(INSTALL_SHORT1) $(INSTALL_SHORT2)
|
||||
cd src && test -f $(FILE_SO) && \
|
||||
$(INSTALL_X) $(FILE_SO) $(INSTALL_DYN) && \
|
||||
- $(LDCONFIG) $(INSTALL_LIB) && \
|
||||
- $(SYMLINK) $(INSTALL_SONAME) $(INSTALL_SHORT1) && \
|
||||
- $(SYMLINK) $(INSTALL_SONAME) $(INSTALL_SHORT2) || :
|
||||
+ ( $(LDCONFIG) $(INSTALL_LIB) ; \
|
||||
+ $(SYMLINK) $(INSTALL_SONAME) $(INSTALL_SHORT1) && \
|
||||
+ $(SYMLINK) $(INSTALL_SONAME) $(INSTALL_SHORT2) || : \
|
||||
+ )
|
||||
cd etc && $(INSTALL_F) $(FILE_MAN) $(INSTALL_MAN)
|
||||
cd etc && $(SED_PC) $(FILE_PC) > $(FILE_PC).tmp && \
|
||||
$(INSTALL_F) $(FILE_PC).tmp $(INSTALL_PC) && \
|
||||
--
|
||||
2.2.2
|
||||
|
25
gnu/packages/patches/luajit-symlinks.patch
Normal file
25
gnu/packages/patches/luajit-symlinks.patch
Normal file
@ -0,0 +1,25 @@
|
||||
From 0a54a8f125d7ab508c7c88d5ad4ed1b0c63cb5b6 Mon Sep 17 00:00:00 2001
|
||||
From: =?utf8?q?Tom=C3=A1=C5=A1=20=C4=8Cech?= <sleep_walker@suse.cz>
|
||||
Date: Wed, 4 Feb 2015 11:32:55 +0100
|
||||
Subject: [PATCH 1/2] Provide two symlinks for dynamic library during install
|
||||
|
||||
---
|
||||
Makefile | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/Makefile b/Makefile
|
||||
index 0891b71..343ecb5 100644
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -56,7 +56,7 @@ INSTALL_PCNAME= luajit.pc
|
||||
INSTALL_STATIC= $(INSTALL_LIB)/$(INSTALL_ANAME)
|
||||
INSTALL_DYN= $(INSTALL_LIB)/$(INSTALL_SONAME)
|
||||
INSTALL_SHORT1= $(INSTALL_LIB)/$(INSTALL_SOSHORT)
|
||||
-INSTALL_SHORT2= $(INSTALL_LIB)/$(INSTALL_SOSHORT)
|
||||
+INSTALL_SHORT2= $(INSTALL_LIB)/$(INSTALL_SOSHORT).$(MAJVER)
|
||||
INSTALL_T= $(INSTALL_BIN)/$(INSTALL_TNAME)
|
||||
INSTALL_TSYM= $(INSTALL_BIN)/$(INSTALL_TSYMNAME)
|
||||
INSTALL_PC= $(INSTALL_PKGCONFIG)/$(INSTALL_PCNAME)
|
||||
--
|
||||
2.2.2
|
||||
|
Loading…
Reference in New Issue
Block a user