gnu: gspell: Update to 1.11.1.
* gnu/packages/gnome.scm (gspell): Update to 1.11.1. [source]: Delete patches. [phases]{disable-problematic-tests}: New phase. [native-inputs]: Remove labels. * gnu/packages/patches/gspell-dash-test.patch: Delete file. * gnu/local.mk (dist_patch_DATA): De-register it.
This commit is contained in:
parent
be1c940d3a
commit
db3d093546
@ -1243,7 +1243,6 @@ dist_patch_DATA = \
|
||||
%D%/packages/patches/groovy-add-exceptionutilsgenerator.patch \
|
||||
%D%/packages/patches/grub-efi-fat-serial-number.patch \
|
||||
%D%/packages/patches/grub-setup-root.patch \
|
||||
%D%/packages/patches/gspell-dash-test.patch \
|
||||
%D%/packages/patches/gst-plugins-good-fix-test.patch \
|
||||
%D%/packages/patches/guile-1.8-cpp-4.5.patch \
|
||||
%D%/packages/patches/guile-2.2-skip-oom-test.patch \
|
||||
|
@ -10838,7 +10838,7 @@ that support the Assistive Technology Service Provider Interface (AT-SPI).")
|
||||
(define-public gspell
|
||||
(package
|
||||
(name "gspell")
|
||||
(version "1.8.2")
|
||||
(version "1.11.1")
|
||||
(source (origin
|
||||
(method url-fetch)
|
||||
(uri (string-append "mirror://gnome/sources/" name "/"
|
||||
@ -10846,13 +10846,18 @@ that support the Assistive Technology Service Provider Interface (AT-SPI).")
|
||||
name "-" version ".tar.xz"))
|
||||
(sha256
|
||||
(base32
|
||||
"1miybm1z5cl91i25l7mfqlxhv7j8yy8rcgi0s1bgbb2vm71rb4dv"))
|
||||
(patches (search-patches "gspell-dash-test.patch"))))
|
||||
"14h2w0yzqwaw5dykmhh21sy2c96g17waahg2lxc52xqiyzis8spg"))))
|
||||
(build-system glib-or-gtk-build-system)
|
||||
(arguments
|
||||
'(#:configure-flags (list "--enable-vala")
|
||||
#:phases
|
||||
(modify-phases %standard-phases
|
||||
(add-after 'unpack 'disable-problematic-tests
|
||||
(lambda _
|
||||
(substitute* "testsuite/test-checker.c"
|
||||
;; This test is known to fail with Aspell, as a comment
|
||||
;; mentions it. Disable it.
|
||||
((".*g_test_add_func.*test_dashes.*") ""))))
|
||||
(add-before 'check 'pre-check
|
||||
(lambda* (#:key inputs #:allow-other-keys)
|
||||
;; Tests require a running X server.
|
||||
@ -10869,18 +10874,20 @@ that support the Assistive Technology Service Provider Interface (AT-SPI).")
|
||||
(inputs
|
||||
(list iso-codes))
|
||||
(native-inputs
|
||||
`(("glib" ,glib "bin")
|
||||
("gobject-introspection" ,gobject-introspection)
|
||||
("pkg-config" ,pkg-config)
|
||||
("vala" ,vala) ;for VAPI, needed by Geary
|
||||
("xmllint" ,libxml2)
|
||||
(list `(,glib "bin")
|
||||
gobject-introspection
|
||||
pkg-config
|
||||
vala ;for VAPI, needed by Geary
|
||||
libxml2
|
||||
|
||||
;; For tests.
|
||||
("aspell-dict-en" ,aspell-dict-en)
|
||||
("xorg-server" ,xorg-server-for-tests)))
|
||||
;; For tests.
|
||||
aspell-dict-en
|
||||
xorg-server-for-tests))
|
||||
(propagated-inputs
|
||||
;; Referred by .pc file.
|
||||
(list enchant glib gtk+))
|
||||
(list enchant
|
||||
glib
|
||||
gtk+))
|
||||
(home-page "https://wiki.gnome.org/Projects/gspell")
|
||||
(synopsis "GNOME's alternative spell checker")
|
||||
(description
|
||||
|
@ -1,22 +0,0 @@
|
||||
Somehow, Aspell 0.60.6.1 and aspell-dict-en-2016.11.20-0 don't consider
|
||||
this a valid spelling. Skip it.
|
||||
|
||||
TODO: Migrate to using hunspell. According to upstream, this bug won't be fixed.
|
||||
See https://bugzilla.gnome.org/show_bug.cgi?id=772406.
|
||||
--- a/testsuite/test-checker.c 2017-03-24 09:50:50.000000000 -0400
|
||||
+++ b/testsuite/test-checker.c 2017-06-15 21:47:07.116173895 -0400
|
||||
@@ -105,10 +105,11 @@
|
||||
* be considered deprecated, it is better to use hunspell, so WONTFIX.
|
||||
* For more details, see:
|
||||
* https://bugzilla.gnome.org/show_bug.cgi?id=772406
|
||||
+ *
|
||||
+ * correctly_spelled = gspell_checker_check_word (checker, "spell-checking", -1, &error);
|
||||
+ * g_assert_no_error (error);
|
||||
+ * g_assert (correctly_spelled);
|
||||
*/
|
||||
- correctly_spelled = gspell_checker_check_word (checker, "spell-checking", -1, &error);
|
||||
- g_assert_no_error (error);
|
||||
- g_assert (correctly_spelled);
|
||||
|
||||
correctly_spelled = gspell_checker_check_word (checker, "nrst-auie", -1, &error);
|
||||
g_assert_no_error (error);
|
Loading…
Reference in New Issue
Block a user