gnu: remove python-fix-dbm.patch
* gnu/packages/patches/python-fix-dbm.patch: remove file. It is not needed anymore, and is probably a left-over of a failed merge. * gnu-system.am: remove gnu/packages/patches/python-fix-dbm.patch
This commit is contained in:
parent
9a9a3adf66
commit
9214f9bc0a
@ -311,7 +311,6 @@ dist_patch_DATA = \
|
|||||||
gnu/packages/patches/perl-no-sys-dirs.patch \
|
gnu/packages/patches/perl-no-sys-dirs.patch \
|
||||||
gnu/packages/patches/plotutils-libpng-jmpbuf.patch \
|
gnu/packages/patches/plotutils-libpng-jmpbuf.patch \
|
||||||
gnu/packages/patches/procps-make-3.82.patch \
|
gnu/packages/patches/procps-make-3.82.patch \
|
||||||
gnu/packages/patches/python-fix-dbm.patch \
|
|
||||||
gnu/packages/patches/python-fix-tests.patch \
|
gnu/packages/patches/python-fix-tests.patch \
|
||||||
gnu/packages/patches/qemu-make-4.0.patch \
|
gnu/packages/patches/qemu-make-4.0.patch \
|
||||||
gnu/packages/patches/qemu-multiple-smb-shares.patch \
|
gnu/packages/patches/qemu-multiple-smb-shares.patch \
|
||||||
|
@ -1,20 +0,0 @@
|
|||||||
This patch allows the dbm module to be built using the compatibility mode of
|
|
||||||
gdbm. It will not be needed any more with Python 2.7.4.
|
|
||||||
--- setup.py 2013-04-06 00:53:37.000000000 +0200
|
|
||||||
+++ setup.py.new 2013-04-06 19:55:05.000000000 +0200
|
|
||||||
@@ -1158,10 +1158,14 @@
|
|
||||||
for cand in dbm_order:
|
|
||||||
if cand == "ndbm":
|
|
||||||
if find_file("ndbm.h", inc_dirs, []) is not None:
|
|
||||||
- # Some systems have -lndbm, others don't
|
|
||||||
+ # Some systems have -lndbm, some have -lgdbm_compat,
|
|
||||||
+ # others have no particular linker flags.
|
|
||||||
if self.compiler.find_library_file(lib_dirs,
|
|
||||||
'ndbm'):
|
|
||||||
ndbm_libs = ['ndbm']
|
|
||||||
+ elif self.compiler.find_library_file(lib_dirs,
|
|
||||||
+ 'gdbm_compat'):
|
|
||||||
+ ndbm_libs = ['gdbm_compat']
|
|
||||||
else:
|
|
||||||
ndbm_libs = []
|
|
||||||
print "building dbm using ndbm"
|
|
Loading…
Reference in New Issue
Block a user