gnu: Remove unused patch 'openldap-CVE-2017-9287.patch'.
This is a followup to commit 47415332d70cd9166b0914ce43018ae57083c120. * gnu/packages/patches/openldap-CVE-2017-9287.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it.
This commit is contained in:
parent
99ee274f0d
commit
800d74dc9a
@ -1090,7 +1090,6 @@ dist_patch_DATA = \
|
||||
%D%/packages/patches/opencv-rgbd-aarch64-test-fix.patch \
|
||||
%D%/packages/patches/openfoam-4.1-cleanup.patch \
|
||||
%D%/packages/patches/openjdk-10-idlj-reproducibility.patch \
|
||||
%D%/packages/patches/openldap-CVE-2017-9287.patch \
|
||||
%D%/packages/patches/openocd-nrf52.patch \
|
||||
%D%/packages/patches/opensmtpd-fix-crash.patch \
|
||||
%D%/packages/patches/openssh-CVE-2018-20685.patch \
|
||||
|
@ -1,37 +0,0 @@
|
||||
Fix CVE-2017-9287:
|
||||
|
||||
https://www.openldap.org/its/?findid=8655
|
||||
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-9287
|
||||
|
||||
Patch copied from upstream source repository:
|
||||
|
||||
https://www.openldap.org/devel/gitweb.cgi?p=openldap.git;a=commit;h=0cee1ffb6021b1aae3fcc9581699da1c85a6dd6e
|
||||
|
||||
From 0cee1ffb6021b1aae3fcc9581699da1c85a6dd6e Mon Sep 17 00:00:00 2001
|
||||
From: Ryan Tandy <ryan@nardis.ca>
|
||||
Date: Wed, 17 May 2017 20:07:39 -0700
|
||||
Subject: [PATCH] ITS#8655 fix double free on paged search with pagesize 0
|
||||
|
||||
Fixes a double free when a search includes the Paged Results control
|
||||
with a page size of 0 and the search base matches the filter.
|
||||
---
|
||||
servers/slapd/back-mdb/search.c | 3 ++-
|
||||
1 file changed, 2 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/servers/slapd/back-mdb/search.c b/servers/slapd/back-mdb/search.c
|
||||
index 301d1a498c..43442aa242 100644
|
||||
--- a/servers/slapd/back-mdb/search.c
|
||||
+++ b/servers/slapd/back-mdb/search.c
|
||||
@@ -1066,7 +1066,8 @@ notfound:
|
||||
/* check size limit */
|
||||
if ( get_pagedresults(op) > SLAP_CONTROL_IGNORED ) {
|
||||
if ( rs->sr_nentries >= ((PagedResultsState *)op->o_pagedresults_state)->ps_size ) {
|
||||
- mdb_entry_return( op, e );
|
||||
+ if (e != base)
|
||||
+ mdb_entry_return( op, e );
|
||||
e = NULL;
|
||||
send_paged_response( op, rs, &lastid, tentries );
|
||||
goto done;
|
||||
--
|
||||
2.13.0
|
||||
|
Loading…
Reference in New Issue
Block a user