gnu: vtk: Fix build with mesa-10.
* gnu/packages/patches/vtk-mesa-10.patch: New file. * gnu-system.am (dist_patch_DATA): Add it. * gnu/packages/vtk.scm (vtk): Add patch. Add glu to inputs.
This commit is contained in:
parent
85f4190221
commit
7f9b77dc46
@ -458,6 +458,7 @@ dist_patch_DATA = \
|
||||
gnu/packages/patches/udev-gir-libtool.patch \
|
||||
gnu/packages/patches/util-linux-perl.patch \
|
||||
gnu/packages/patches/vpnc-script.patch \
|
||||
gnu/packages/patches/vtk-mesa-10.patch \
|
||||
gnu/packages/patches/w3m-fix-compile.patch \
|
||||
gnu/packages/patches/wmctrl-64-fix.patch \
|
||||
gnu/packages/patches/xf86-video-ark-remove-mibstore.patch \
|
||||
|
36
gnu/packages/patches/vtk-mesa-10.patch
Normal file
36
gnu/packages/patches/vtk-mesa-10.patch
Normal file
@ -0,0 +1,36 @@
|
||||
Fix build against new mesa. See:
|
||||
|
||||
https://bugs.freedesktop.org/show_bug.cgi?id=83631
|
||||
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=765938
|
||||
|
||||
Description: fixes FTBFS against new libjpeg-turbo
|
||||
Author: Ondřej Surý <ondrej@debian.org>
|
||||
Bug-Debian: https://bugs.debian.org/765938
|
||||
Reviewed-By: Anton Gladky <gladk@debian.org>
|
||||
Last-Update: 2014-10-22
|
||||
|
||||
Index: vtk6-6.1.0+dfsg2/Rendering/OpenGL/vtkOpenGL.h
|
||||
===================================================================
|
||||
--- vtk6-6.1.0+dfsg2.orig/Rendering/OpenGL/vtkOpenGL.h
|
||||
+++ vtk6-6.1.0+dfsg2/Rendering/OpenGL/vtkOpenGL.h
|
||||
@@ -20,6 +20,7 @@
|
||||
|
||||
// To prevent gl.h to include glext.h provided by the system
|
||||
#define GL_GLEXT_LEGACY
|
||||
+#define GLX_GLEXT_LEGACY
|
||||
#if defined(__APPLE__) && (defined(VTK_USE_CARBON) || defined(VTK_USE_COCOA))
|
||||
# include <OpenGL/gl.h> // Include OpenGL API.
|
||||
#else
|
||||
Index: vtk6-6.1.0+dfsg2/Rendering/OpenGL/vtkXOpenGLRenderWindow.cxx
|
||||
===================================================================
|
||||
--- vtk6-6.1.0+dfsg2.orig/Rendering/OpenGL/vtkXOpenGLRenderWindow.cxx
|
||||
+++ vtk6-6.1.0+dfsg2/Rendering/OpenGL/vtkXOpenGLRenderWindow.cxx
|
||||
@@ -27,7 +27,7 @@
|
||||
|
||||
// define GLX_GLXEXT_LEGACY to prevent glx.h to include glxext.h provided by
|
||||
// the system
|
||||
-//#define GLX_GLXEXT_LEGACY
|
||||
+#define GLX_GLXEXT_LEGACY
|
||||
#include "GL/glx.h"
|
||||
|
||||
#include "vtkgl.h"
|
@ -1,5 +1,6 @@
|
||||
;;; GNU Guix --- Functional package management for GNU
|
||||
;;; Copyright © 2014 Ludovic Courtès <ludo@gnu.org>
|
||||
;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
|
||||
;;;
|
||||
;;; This file is part of GNU Guix.
|
||||
;;;
|
||||
@ -21,6 +22,7 @@
|
||||
#:use-module (guix download)
|
||||
#:use-module (guix licenses)
|
||||
#:use-module (guix build-system cmake)
|
||||
#:use-module (gnu packages)
|
||||
#:use-module (gnu packages xorg)
|
||||
#:use-module (gnu packages gl))
|
||||
|
||||
@ -36,7 +38,8 @@
|
||||
"/VTK-" version ".tar.gz"))
|
||||
(sha256
|
||||
(base32
|
||||
"0d7shccdkyj4mbh2riilslgx3gd28in4c7xpm0lxa1ln8w5g2zdx"))))
|
||||
"0d7shccdkyj4mbh2riilslgx3gd28in4c7xpm0lxa1ln8w5g2zdx"))
|
||||
(patches (list (search-patch "vtk-mesa-10.patch")))))
|
||||
(build-system cmake-build-system)
|
||||
(arguments
|
||||
;; Build without '-g' to save space.
|
||||
@ -46,7 +49,8 @@
|
||||
`(("libXt" ,libxt)
|
||||
("xproto" ,xproto)
|
||||
("libX11" ,libx11)
|
||||
("mesa" ,mesa)))
|
||||
("mesa" ,mesa)
|
||||
("glu" ,glu)))
|
||||
(home-page "http://www.vtk.org/")
|
||||
(synopsis "Libraries for 3D computer graphics")
|
||||
(description
|
||||
|
Loading…
Reference in New Issue
Block a user