gnu: ruby-yard: Update to 0.9.6.
* gnu/packages/ruby.scm (ruby-yard): Update to 0.9.6. [source]: Use 'GitHub' source. [arguments]: Run tests without 'Rakefile'. [native-inputs]: Replace 'ruby-rspec-2' with ruby-rspec'. * gnu/packages/patches/ruby-yard-fix-skip-of-markdown-tests.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it.
This commit is contained in:
parent
57fe28a082
commit
6499893ef8
@ -844,7 +844,6 @@ dist_patch_DATA = \
|
||||
%D%/packages/patches/ruby-puma-ignore-broken-test.patch \
|
||||
%D%/packages/patches/ruby-rack-ignore-failing-test.patch \
|
||||
%D%/packages/patches/ruby-tzinfo-data-ignore-broken-test.patch\
|
||||
%D%/packages/patches/ruby-yard-fix-skip-of-markdown-tests.patch \
|
||||
%D%/packages/patches/sed-hurd-path-max.patch \
|
||||
%D%/packages/patches/scheme48-tests.patch \
|
||||
%D%/packages/patches/scotch-test-threading.patch \
|
||||
|
@ -1,17 +0,0 @@
|
||||
The tests currently fail due to use of 'skip' rather than 'pending' to skip a
|
||||
test usually not skipped by upstream. This patch has been proposed upstream
|
||||
at https://github.com/lsegal/yard/pull/1033
|
||||
|
||||
diff --git a/spec/templates/helpers/html_helper_spec.rb b/spec/templates/helpers/html_helper_spec.rb
|
||||
index 84624c3..9c4fc2b 100644
|
||||
--- a/spec/templates/helpers/html_helper_spec.rb
|
||||
+++ b/spec/templates/helpers/html_helper_spec.rb
|
||||
@@ -184,7 +184,7 @@ describe YARD::Templates::Helpers::HtmlHelper do
|
||||
it "creates tables (markdown specific)" do
|
||||
log.enter_level(Logger::FATAL) do
|
||||
unless markup_class(:markdown).to_s == "RedcarpetCompat"
|
||||
- skip "This test depends on a markdown engine that supports tables"
|
||||
+ pending "This test depends on a markdown engine that supports tables"
|
||||
end
|
||||
end
|
||||
|
@ -3049,44 +3049,40 @@ features such as filtering and fine grained logging.")
|
||||
(license license:expat)))
|
||||
|
||||
(define-public ruby-yard
|
||||
;; Use git reference because gem is >100 commits out of date and the tests
|
||||
;; do not pass with the released gem.
|
||||
(let ((commit "d816482a0d4850506c3bcccc9434550c536c28c6"))
|
||||
(package
|
||||
(name "ruby-yard")
|
||||
(version (string-append "0.9.5-1." (string-take commit 8)))
|
||||
(source
|
||||
(origin
|
||||
(method git-fetch)
|
||||
(uri (git-reference
|
||||
(url "https://github.com/lsegal/yard.git")
|
||||
(commit commit)))
|
||||
(file-name (string-append name "-" version "-checkout"))
|
||||
(sha256
|
||||
(base32
|
||||
"1j16c85x22if7y0fzi3c900p9wzkx2riq1y7vsj92a0zvwsxai4i"))
|
||||
(patches (search-patches "ruby-yard-fix-skip-of-markdown-tests.patch"))))
|
||||
(build-system ruby-build-system)
|
||||
(arguments
|
||||
`(#:test-target "spec"
|
||||
#:phases
|
||||
(modify-phases %standard-phases
|
||||
(add-before 'check 'set-HOME-and-disable-failing-test
|
||||
(lambda _
|
||||
;; $HOME needs to be set to somewhere writeable for tests to run
|
||||
(setenv "HOME" "/tmp")
|
||||
#t)))))
|
||||
(native-inputs
|
||||
`(("ruby-rspec" ,ruby-rspec-2)
|
||||
("ruby-rack" ,ruby-rack)))
|
||||
(synopsis "Documentation generation tool for Ruby")
|
||||
(description
|
||||
"YARD is a documentation generation tool for the Ruby programming
|
||||
(package
|
||||
(name "ruby-yard")
|
||||
(version "0.9.6")
|
||||
(source
|
||||
(origin
|
||||
(method url-fetch)
|
||||
;; Tests do not pass if we build from the distributed gem.
|
||||
(uri (string-append "https://github.com/lsegal/yard/archive/v"
|
||||
version "tar.gz"))
|
||||
(file-name (string-append name "-" version ".tar.gz"))
|
||||
(sha256
|
||||
(base32
|
||||
"0rsz4bghgx7fryzyhlz8wlnd2m9xgyvf1xhrq58mnzfrrfm41bdg"))))
|
||||
(build-system ruby-build-system)
|
||||
(arguments
|
||||
`(#:phases
|
||||
(modify-phases %standard-phases
|
||||
(replace 'check
|
||||
(lambda _
|
||||
;; $HOME needs to be set to somewhere writeable for tests to run
|
||||
(setenv "HOME" "/tmp")
|
||||
;; Run tests without using 'rake' to avoid dependencies.
|
||||
(zero? (system* "rspec")))))))
|
||||
(native-inputs
|
||||
`(("ruby-rspec" ,ruby-rspec)
|
||||
("ruby-rack" ,ruby-rack)))
|
||||
(synopsis "Documentation generation tool for Ruby")
|
||||
(description
|
||||
"YARD is a documentation generation tool for the Ruby programming
|
||||
language. It enables the user to generate consistent, usable documentation
|
||||
that can be exported to a number of formats very easily, and also supports
|
||||
extending for custom Ruby constructs such as custom class level definitions.")
|
||||
(home-page "http://yardoc.org")
|
||||
(license license:expat))))
|
||||
(home-page "http://yardoc.org")
|
||||
(license license:expat)))
|
||||
|
||||
(define-public ruby-clap
|
||||
(package
|
||||
|
Loading…
Reference in New Issue
Block a user