gnu: ccache: Upgrade to 3.1.10.
* gnu/packages/ccache.scm (ccache): Upgrade to 3.1.10. [source]: Remove patches. * gnu/packages/patches/ccache-stdc-predef-test.patch: Delete patch. * gnu-system.am (dist_patch_DATA): Remove it.
This commit is contained in:
parent
7947a05439
commit
1454a2ba88
@ -312,7 +312,6 @@ dist_patch_DATA = \
|
||||
gnu/packages/patches/bigloo-gc-shebangs.patch \
|
||||
gnu/packages/patches/binutils-ld-new-dtags.patch \
|
||||
gnu/packages/patches/binutils-loongson-workaround.patch \
|
||||
gnu/packages/patches/ccache-stdc-predef-test.patch \
|
||||
gnu/packages/patches/cdparanoia-fpic.patch \
|
||||
gnu/packages/patches/clucene-pkgconfig.patch \
|
||||
gnu/packages/patches/cmake-fix-tests.patch \
|
||||
|
@ -28,7 +28,7 @@
|
||||
(define-public ccache
|
||||
(package
|
||||
(name "ccache")
|
||||
(version "3.1.9")
|
||||
(version "3.1.10")
|
||||
(source
|
||||
(origin
|
||||
(method url-fetch)
|
||||
@ -36,8 +36,7 @@
|
||||
version ".tar.xz"))
|
||||
(sha256
|
||||
(base32
|
||||
"1i06015jjc0n55xgvhv2h37fjp0i7z8a10s0v40f87c5mprzv0a9"))
|
||||
(patches (list (search-patch "ccache-stdc-predef-test.patch")))))
|
||||
"0mr8n1nbykxw4rs55ad8wd6xmfhihn09mxpxb91sn9mlsd1ryhw8"))))
|
||||
(build-system gnu-build-system)
|
||||
(native-inputs `(("perl" ,perl))) ;for test.sh
|
||||
(inputs `(("zlib" ,zlib)))
|
||||
|
@ -1,157 +0,0 @@
|
||||
This patch is a combination of the following commits::
|
||||
|
||||
https://git.samba.org/?p=ccache.git;a=commit;h=b5d63f81c1a83fd4c50b769a96a04f581b7db70c
|
||||
https://git.samba.org/?p=ccache.git;a=commit;h=a11f5688748ecb49f590b3f4bc0e9b3458f9a56f
|
||||
https://git.samba.org/?p=ccache.git;a=commit;h=5a9322c56ed0cd16255966e99077843aae57ab3e
|
||||
|
||||
from the general discussion at
|
||||
http://comments.gmane.org/gmane.comp.compilers.ccache/1089
|
||||
|
||||
--- a/test.sh
|
||||
+++ b/test.sh
|
||||
@@ -562,6 +562,12 @@
|
||||
EOF
|
||||
backdate test1.h test2.h test3.h
|
||||
|
||||
+ $COMPILER -c -Wp,-MD,expected.d test.c
|
||||
+ expected_d_content=`cat expected.d`
|
||||
+
|
||||
+ $COMPILER -c -Wp,-MMD,expected_mmd.d test.c
|
||||
+ expected_mmd_d_content=`cat expected_mmd.d`
|
||||
+
|
||||
##################################################################
|
||||
# First compilation is a miss.
|
||||
testname="first compilation"
|
||||
@@ -677,7 +683,7 @@
|
||||
checkstat 'cache hit (direct)' 0
|
||||
checkstat 'cache hit (preprocessed)' 0
|
||||
checkstat 'cache miss' 1
|
||||
- checkfile other.d "test.o: test.c test1.h test3.h test2.h"
|
||||
+ checkfile other.d "$expected_d_content"
|
||||
|
||||
rm -f other.d
|
||||
|
||||
@@ -685,7 +691,7 @@
|
||||
checkstat 'cache hit (direct)' 1
|
||||
checkstat 'cache hit (preprocessed)' 0
|
||||
checkstat 'cache miss' 1
|
||||
- checkfile other.d "test.o: test.c test1.h test3.h test2.h"
|
||||
+ checkfile other.d "$expected_d_content"
|
||||
|
||||
rm -f other.d
|
||||
|
||||
@@ -698,7 +704,7 @@
|
||||
checkstat 'cache hit (direct)' 0
|
||||
checkstat 'cache hit (preprocessed)' 0
|
||||
checkstat 'cache miss' 1
|
||||
- checkfile other.d "test.o: test.c test1.h test3.h test2.h"
|
||||
+ checkfile other.d "$expected_mmd_d_content"
|
||||
|
||||
rm -f other.d
|
||||
|
||||
@@ -706,7 +712,7 @@
|
||||
checkstat 'cache hit (direct)' 1
|
||||
checkstat 'cache hit (preprocessed)' 0
|
||||
checkstat 'cache miss' 1
|
||||
- checkfile other.d "test.o: test.c test1.h test3.h test2.h"
|
||||
+ checkfile other.d "$expected_mmd_d_content"
|
||||
|
||||
rm -f other.d
|
||||
|
||||
@@ -760,7 +766,7 @@
|
||||
checkstat 'cache hit (direct)' 0
|
||||
checkstat 'cache hit (preprocessed)' 0
|
||||
checkstat 'cache miss' 1
|
||||
- checkfile test.d "test.o: test.c test1.h test3.h test2.h"
|
||||
+ checkfile test.d "$expected_d_content"
|
||||
|
||||
rm -f test.d
|
||||
|
||||
@@ -768,7 +774,7 @@
|
||||
checkstat 'cache hit (direct)' 1
|
||||
checkstat 'cache hit (preprocessed)' 0
|
||||
checkstat 'cache miss' 1
|
||||
- checkfile test.d "test.o: test.c test1.h test3.h test2.h"
|
||||
+ checkfile test.d "$expected_d_content"
|
||||
|
||||
##################################################################
|
||||
# Check the scenario of running a ccache with direct mode on a cache
|
||||
@@ -780,7 +786,7 @@
|
||||
checkstat 'cache hit (direct)' 0
|
||||
checkstat 'cache hit (preprocessed)' 0
|
||||
checkstat 'cache miss' 1
|
||||
- checkfile test.d "test.o: test.c test1.h test3.h test2.h"
|
||||
+ checkfile test.d "$expected_d_content"
|
||||
|
||||
rm -f test.d
|
||||
|
||||
@@ -788,7 +794,7 @@
|
||||
checkstat 'cache hit (direct)' 0
|
||||
checkstat 'cache hit (preprocessed)' 1
|
||||
checkstat 'cache miss' 1
|
||||
- checkfile test.d "test.o: test.c test1.h test3.h test2.h"
|
||||
+ checkfile test.d "$expected_d_content"
|
||||
|
||||
rm -f test.d
|
||||
|
||||
@@ -796,7 +802,7 @@
|
||||
checkstat 'cache hit (direct)' 0
|
||||
checkstat 'cache hit (preprocessed)' 2
|
||||
checkstat 'cache miss' 1
|
||||
- checkfile test.d "test.o: test.c test1.h test3.h test2.h"
|
||||
+ checkfile test.d "$expected_d_content"
|
||||
|
||||
rm -f test.d
|
||||
|
||||
@@ -804,7 +810,7 @@
|
||||
checkstat 'cache hit (direct)' 1
|
||||
checkstat 'cache hit (preprocessed)' 2
|
||||
checkstat 'cache miss' 1
|
||||
- checkfile test.d "test.o: test.c test1.h test3.h test2.h"
|
||||
+ checkfile test.d "$expected_d_content"
|
||||
|
||||
##################################################################
|
||||
# Check that -MF works.
|
||||
@@ -815,7 +821,7 @@
|
||||
checkstat 'cache hit (direct)' 0
|
||||
checkstat 'cache hit (preprocessed)' 0
|
||||
checkstat 'cache miss' 1
|
||||
- checkfile other.d "test.o: test.c test1.h test3.h test2.h"
|
||||
+ checkfile other.d "$expected_d_content"
|
||||
|
||||
rm -f other.d
|
||||
|
||||
@@ -823,7 +829,7 @@
|
||||
checkstat 'cache hit (direct)' 1
|
||||
checkstat 'cache hit (preprocessed)' 0
|
||||
checkstat 'cache miss' 1
|
||||
- checkfile other.d "test.o: test.c test1.h test3.h test2.h"
|
||||
+ checkfile other.d "$expected_d_content"
|
||||
|
||||
##################################################################
|
||||
# Check that a missing .d file in the cache is handled correctly.
|
||||
@@ -835,13 +841,13 @@
|
||||
checkstat 'cache hit (direct)' 0
|
||||
checkstat 'cache hit (preprocessed)' 0
|
||||
checkstat 'cache miss' 1
|
||||
- checkfile other.d "test.o: test.c test1.h test3.h test2.h"
|
||||
+ checkfile other.d "$expected_d_content"
|
||||
|
||||
$CCACHE $COMPILER -c -MD test.c
|
||||
checkstat 'cache hit (direct)' 1
|
||||
checkstat 'cache hit (preprocessed)' 0
|
||||
checkstat 'cache miss' 1
|
||||
- checkfile other.d "test.o: test.c test1.h test3.h test2.h"
|
||||
+ checkfile other.d "$expected_d_content"
|
||||
|
||||
find $CCACHE_DIR -name '*.d' -exec rm -f '{}' \;
|
||||
|
||||
@@ -849,7 +855,7 @@
|
||||
checkstat 'cache hit (direct)' 1
|
||||
checkstat 'cache hit (preprocessed)' 1
|
||||
checkstat 'cache miss' 1
|
||||
- checkfile other.d "test.o: test.c test1.h test3.h test2.h"
|
||||
+ checkfile other.d "$expected_d_content"
|
||||
|
||||
##################################################################
|
||||
# Check that stderr from both the preprocessor and the compiler is emitted
|
Loading…
Reference in New Issue
Block a user