20 lines
373 B
Nix
20 lines
373 B
Nix
# REF(Krey): Exit policy https://gitlab.torproject.org/legacy/trac/-/wikis/doc/ReducedExitPolicy
|
|
{ config, lib,... }: lib.mkIf config.services.tor.relay.enable {
|
|
networking.firewall.allowedTCPPorts = [ 36821 ];
|
|
|
|
services = {
|
|
tor = {
|
|
relay = {
|
|
role = "exit";
|
|
};
|
|
client = {
|
|
dns.enable = true;
|
|
};
|
|
settings = {
|
|
ORPort = "auto";
|
|
};
|
|
};
|
|
};
|
|
}
|
|
|